giovedì 19 novembre 2009

Togliere fruscio di fondo da Ubuntu 9.10

Per risparmiare energia Karmic disattiva l'audio quando non usato, questa nuova e nobile opzione non sempre funziona correttamente, ma d'altra parte non è cosa rara con la nostra Ubuntu, fra alsa e pulseaudio i problemi sonori sono quasi normalità.
Sul samsung NC10 l'opzione si trasforma in un continuo fruscio di fondo che smette solo quando si attiva qualche suono, per togliere il leggero ma continuo ronzio bisogna disattivare l'opzione del risparmio energetico, da terminale:
  • sudo gedit /etc/modprobe.d/alsa-base.conf
In fondo al file che si apre dovrebbero esserci queste righe:
# Power down HDA controllers after 10 idle seconds
options snd-hda-intel power_save=10 power_save_controller=N

Bisogna mettere il cancelletto(#) prima di "options" e salvare:
# Power down HDA controllers after 10 idle seconds
#options snd-hda-intel power_save=10 power_save_controller=N

Al riavvio non dovreste più sentire il brusio.

8 commenti:

Anonimo ha detto...

BOOOOMBA!!!
FUNZIONA! Anche sul mio notebook HP serie 6000 scheda hda intel.
Io udivo in altoparlante/cuffia un forte click...pausa, poi due click quasi consecutivi...lunga pausa ed il ciclo si ripeteva. Vero è che quando ascoltavo audio da youtube, streaming,CD, altro..niente click ne disturbi.PERO'
Fortuna che ci sono in rete persone come TE che volano su linux e che elargiscono consigli!!! GRAZIE MILLE

ukuntu ha detto...

Di niente, son contento che sia servito anche a te e che tu mi abbia lasciato un messaggio.

diesisebemolle ha detto...

in questo thread http://forum.ubuntu-it.org/index.php/topic,343353.new.html ci sono i ringraziamenti che doverosamente ti giro. :-D

nicotano

ukuntu ha detto...

Grazie nicotano

Sergio ha detto...

Ciao, ho provato anch'io a fare l'operazione ma il fruscio rimane che posso fare?

ukuntu ha detto...

Vuol dire che il fruscio è dovuto ad altre cause, potresti provare a controllare che non sia dovuto a valori di volume impostati al massimo.

Dai "alsamixer" da terminale e guarda se le colonnine sono al massimo del rosso e, in tal caso, prova ad abbassarle un po'.

Sergio ha detto...

Grazie, ho provato con Alsamixer ma non ci sono valori in rosso, la cosa strana è che è come se ci fosse un microfono aperto.. ma ho fatto tutte le prove e non cambia nulla grazie ancora se puoi essermi d'aiuto.. Ciao Sergio.

ukuntu ha detto...

Dovresti essere più chiaro.

Il fruscio lo senti sempre?
Il fruscio lo fa anche se colleghi degli auricolari?
Stai facendo queste prove con le modifiche del mio post? Hai controllato di aver salvato?
Cosa vuol dire sembra esserci un microfono aperto?
Che versione di Ubuntu usi? Su che computer?

Related Posts with Thumbnails