sabato 12 dicembre 2009

Soluzione rimozione pacchetto adobe-flashplugin bloccata

Volevo aggiornare ad una nuova versione di flash e per rimuovere quella vecchia ho dato da terminale:
  • sudo apt-get remove adobe-flashplugin
che mi ha restituito il seguente errore:

il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 1
Si sono verificati degli errori nell'elaborazione:
adobe-flashplugin
E: Sub-process /usr/bin/dpkg returned an error code (1)

Praticamente non riuscivo a disintallare il pacchetto, per risolvere da terminale:
  • sudo gedit /var/lib/dpkg/info/adobe-flashplugin.prerm
e quindi inserire exit 0 subito sotto la prima riga #!/bin/sh, salvare.
Ora si può ridare da terminale:
  • sudo apt-get remove adobe-flashplugin
Si dovrebbe rimuovere senza ulteriori problemi e quindi proseguire per installare la nuova versione.

[Fonte: rivisitazione di questo post]

0 commenti:

Related Posts with Thumbnails